
Photomask Design Using L-Edit Pro 

1. Overview  
This manual provides a quick tutorial on the procedure to obtaining a set of masks using  
L-Edit Pro program.  For more detailed information on L-Edit, please use Help within the 
program. 

2. L-Edit Quick Reference 
2.1. How to Access the L-Edit Program:  

The L-Edit program is situated in the “Mask Design Computer” in J-wing atrium of the 
Engineering Quadrangle building.  To obtain password to the computer please contact 
Helena Gleskova or Joe Palmer.  To access the program click on the L-Edit v 10.20 icon 
located on the desktop of the computer.  

2.2. Before Starting … useful definitions: 

Technology 
A technology is the equivalent of one layer in a mask design.  L-Edit supports an 
unlimited number of technology layers.  These are displayed in the layer palette as an 
arrangement of square icons that represents the available layers. The icons are 
differentiated by color and pattern.  

2.3. The Program Layout: 
The program layout contains three distinct areas. The first area is known as the work 
area.  This is the grayish-colored central region where mask designs are constructed. It is 
best to think of the work area as a large sheet of paper. The second area is the menu bar. 
This is located at the very top of the program screen. It provides access to all of the major 
features of the program, including view control and special options such as the design 
rule checker. The third and last area consists of the toolbars. These include the standard 
toolbar for basic operations, the drawing toolbar for creating the mask design, the layer 
palette for selecting the appropriate layer in the mask design, and the locator to help 
determine the desired location of objects within the work area. (To view all the layers in 
the layer palette, make sure to scroll left in the toolbar). 

2.4. The Program Settings: 
The current default in the L-Edit program differs from the one that the program initially 
decided to implement.  Both contain the same toolbars and overall layout; however, the 
new default has been modified so that somebody completely new to the program might 
be able to design and develop new photomasks in very little time. 

Let us start out with the menu bar. Click on the word View.  As one can see, a series of 
check marks runs down the options.  To make sure nothing is kept out of view while 
creating a new layout, check to see if the following options are selected in Display: icon, 
arrays, ports, grid, origin, and mouse hints.  Also, under View > Status Bars all bars 



should be selected.  If, for any reason, the options become difficult to work with, they can 
be turned off simply by selecting the option. 

*** This next paragraph is very important. Click on the word Setup.  The Setup screen 
should drop down. Now select Design.  What should appear are five folders with only 
their tabs showing - the first one, technology, viewed entirely.  The remaining tabs 
should be labeled grid, selection, drawing, and Xref files (see diagrams).  The first 
folder, technology, serves to establish the display units and the technology units that are 
to be used in the layout, as well as specify the internal unit (in microns).  (Internal units 
are the smallest possible units available in the L-Edit program).  The default setting is 1 
internal unit = 1/1000 microns.   

To aid the viewing, drawing, and editing of objects, L-Edit provides three 
independent grids - the grid display, the mouse grid, and the manufacturing grid – each 
of which divides the layout area into equal squares whose corners act as gridpoints.  The 
settings for these grids can be found in the grid folder that appears in the middle diagram 
above.  The first group of settings deals with the grid display.  The grid display setting 
regulates the absolute spacing, in microns, between the major and minor gridpoints in the 
displayed grid.  The default settings are: Major display grid 10 microns, Suppress major 
grid if less than 20 pixels, Display minor grid 1 micron, and Suppress minor grid if less 
than 8 pixels.  Another setting that can be regulated, if desired, is the suppress grid if less 
than.  If you enter a number larger than 87 for the major grid, or larger than 8 for the 
minor grid, then the corresponding grid is hidden. 

The second group of settings controls the mouse grid. Cursor type is a setting that allows 
the user to decide between two types of pointers - a snapping pointer, where the only 
possible positions of the pointer are located at the mouse snap gridpoints, or a smooth 
pointer, where the pointer’s position is unconstrained.  Despite the choice, the default 
prefers that the user select a snapping pointer for convenience in drawing and editing.  
The second setting, mouse snap grid, simply sets the absolute spacing of the mouse snap 
grid.  The default value is 1 micron.   

The third folder, selection, has only one important setting.  Selection range is basically 
the furthest distance (in microns) that one can move outside of an object with the pointer 
still be able to select it. 

*** While settings can be changed as necessary, it is suggested that they remain as they 
appear in the previous diagrams for reasons benefiting the L-Edit beginner. As one 
becomes more experienced with creating layouts, changes should then be considered 
(when appropriate). 

2.5. Program Options: 
Although it is highly recommended that the L-Edit beginner stick with the default 
settings, changes can be made for general applications.  To do so, select Setup > 
Application from the main menu.  Once accessed, one may change editing options, 
adjust toolbars, and establish keyboard shortcuts. 



2.6. Drawing in the Layout: 
Drawing in L-Edit is not as complicated as it may seem.  The best suggestion that can be 
made to a beginning L-Edit user, however, is to tinker and play with all the features that 
the drawing toolbar has to offer.  It may take a little more time than reading a manual, but 
it will definitely pay off. 

Boxes 
Not only are boxes commonly used in circuit design, but they are also very easy to draw.  
Start by clicking the icon with the white rectangular box on it.  Once the icon is selected, 
move the pointer to any area on the grid display (using the locator coordinate system as a 
guide) and click the desired point, making sure to hold down the mouse button.  This is 
one corner of the box (called the anchor point).  Now move the pointer to the intended 
opposite corner of the box and release the mouse button. 

Circles 
Circles, although used less often, are also very easy to make.  Just as before, select an 
icon - this time it should be a circle.  Start with an anchor point, which will act as the 
center of the circle.  Select the desired location of the anchor point, click and hold the 
mouse button, move outward to any point, and release the mouse button when the 
selection is complete.  The distance between the anchor point and the "outward point" is 
the radius of the circle.  

Triangles 
To make a triangle, first click on the icon represented by a triangle.  Once the icon is 
selected, move the pointer to the grid display.  Click the mouse button at the desired 
anchor point.  This will act as one of the triangle’s vertices.  Move the pointer to a second 
point and click on that spot.  This is the second vertex.  Finally, move to a third spot and 
click the right mouse button.  The triangle should now be complete.  If one desires 
greater-sided angled polygons, the first two steps should be repeated for more vertices. 

Wires 
A wire consists of one or more rectangular segments joined at common ends.  All 
segments in the wire have the same width, but each segment can have a different length.  
To draw a wire, first click on one of the wire icons (there are three to be exact).  The first 
in the series allows only horizontal and vertical lines.  The second includes 45° lines.  
The third is capable of drawing wires of all angles.  Once a wire icon is chosen, select an 
area on the grid display where the wire is to begin.  Click on this spot with the mouse 
button.  To extend the wire, move to a second area and click on the mouse button again.  
This action can be continued for wires of indefinite length.  Once the desired wire is 
sketched, click on the right mouse button to complete the wire design.  (See Setup > 
Layers > General for default wire settings). 

Note: Just because a wire appears to touch another object on the screen does not 
necessarily mean that it will form a connection during chip fabrication. 

Polygons, Arcs, and Tori 



These odd shapes are seldom used in the L-Edit program. If one desires to implement 
them in a design, refer to the L-Edit User Manual.  Simply practicing with these icons 
will help tremendously. 

2.7. Drawing Options: 
Sometimes the L-Edit user may not be satisfied with the layers available in the layer 
palette.  To change a layer (color, pattern, etc.), double-click on the desired layer.  This 
should bring up the Setup Layers screen. (This screen can also be accessed through the 
main menu – Setup > Layers).  Once this is done, the user can change the various 
properties associated with individual layers.  Under the General tab, one may adjust 
default wire settings and tinker with electrical properties.  To change layer colors or 
patterns, however, one must click on the Rendering tab.  Here, the user may change a 
layer’s color, mode (set or clear), and stipple (pattern).  One may add or delete layers 
from all tabs.  

The following options are useful in drawing and viewing various objects within the 
layout: 

Flip/Rotate  
Once objects are drawn, they can be flipped or rotated accordingly to fit the user’s needs.  
To rotate an object 90°, simply select Draw > Rotate from the main menu, press R on the 
keyboard, or click on the icon that contains a shaded triangle standing up, an unshaded 
triangle laying down, and an arrow pointing from the unshaded triangle to the shaded 
triangle.  

To flip an object (like one would flip a pancake), select Draw > Flip > Horizontal or 
Vertical from the main menu, press H for a horizontal flip or V for a vertical flip, or click 
on the flip icons – represented by shaded and unshaded triangles.  

Hiding/Showing Layers 
When dealing with multiple layers in a mask design, it is often necessary to view only 
certain layers at a time.  To hide a particular layer, first select the layer from the layer 
palette.  Double click the layer icon with the right mouse button.  A screen should pop up 
and read Show... and then a layer name.  Click on this to hide the specific layer.  Click on 
it again to show the specific layer.  The procedure can be repeated to Show All or Hide 
All layers. (When Show All is clicked, all layers are shown, regardless of the layer the 
process is started with. When Hide All is clicked, all layers are hidden except the layer 
the process is started with.) The same series of steps can be used to increase icon size, 
decrease icon size, turn on/off toolbars, etc…. (The hide/show commands can also be 
accessed through the main menu - View > Layers > …). 

Moving Objects 
To move an object, first click on the object to be moved.  Once the object is selected, 
hold down the Alt key and click-and-hold the mouse button.  The object is now free to be 
moved.  Once finished, simply release the mouse button.  To move a large number of 
objects, simply select more objects and repeat the procedure. 



Another way to move objects in the L-Edit program is through Edit > Edit Object(s).  
This provides an exact way of placing objects in the layout using X-Y coordinate system 
(in microns). 

Select All 
Many times the L-Edit user may find it necessary to select all of the objects in the layout.  
To do so, select Edit > Select All from the main menu or press Ctrl + A on the keyboard. 

Selecting Objects 
To select a single object, click the object with the mouse button.  To select more than one 
object, click on the mouse-pointer icon in the drawing toolbar and draw a box around the 
desired objects.  Whatever objects are captured entirely by the box will be selected. 

Undo/Redo 
Objects can be undone and redone through the use of two icons in the standard toolbar.  
The undo icon is represented by an arrow emerging out of a page and bending toward the 
left.  The redo icon is represented by an arrow emerging out of a page and bending 
toward the right.  (Undo is the equivalent of pressing Ctrl + Z on the keyboard.  Redo is 
the equivalent of pressing Ctrl + Y on the keyboard.)  

2.8 Viewing Options: 

The following options are very helpful in locating, viewing, and observing various 
objects within the layout: 

Home  
One helpful options that is very similar to the zoom option is the Home key.  To view the 
entire layout, press the Home key on the keyboard.  The program automatically sets the 
zoom to include all of the objects in the design.   

Pan 
The pan command allows one to move the viewing area to a desired location.  Panning, 
which can only be done horizontally and vertically, requires the use of the arrow keys. 

Zoom 
Zooming in (for increased magnification) requires pressing the "+" key on the keyboard. 
Zooming out can be done by pressing the "-" key.  These options are used very often. 

2.9.  Saving Files: 
To save a modified file in the L-Edit program, simply click on File in the menu bar and 
scroll down to Save.  Select this option and save the file as desired.  It is recommended, 
however, that any personal file be stored in C:\Documents and Settings\YourFolder. 

Note: When creating and saving individual cells, do not use parentheses or 
slashes/dashes of any kind.  When possible, do not even use spaces.  Letters (capital 
preferred) and numbers are allowed. 



2.10.  Creating Larger Photomasks: 
As stated before, a technology is the equivalent of one layer in a mask design.  L-Edit 
supports an unlimited number of technology layers.  These are displayed in the layer 
palette as an arrangement of square icons that represents the available layers…. What 
does this all mean? 

Well, first of all, L-Edit opens with one cell (or drawing window).  This cell can be used 
to create very simple photomasks; however, more complicated photomasks require more 
attention.  One simple way to go about making larger photomasks is to begin by drawing 
very articulate and detailed sections of the intended mask design in individual cells and 
then instancing them into a final cell.  By this way, what would take days will take only a 
few hours. 

Note:  Each cell in a project should be contained within the same file.  In the drawing 
below, the file Pattern Components contains the project cell Test Pattern which, in turn, is 
made up of all the other cells in the file. 

Many photomasks require that more than one layer appear on the final design.  This may 
be done by creating individual mask components of a particular layer and then instancing 
them as desired, paying particular attention to placement within the layout.  Often it is 
more convenient to use one cell to include a several-layer structure, which is less prone to 
placement errors.  In the diagram on the next page, each set of numbers, lines, and boxes 
was initially drawn in an individual cell and then transferred into the project cell called 
Test Pattern.  Accurate positioning can be accomplished with help from the locator 
coordinate system.  (Only two layers were used). 

The Select Cell to Edit box in the picture above shows how cells are used in a mask 
design. The whole mask is stored under one file.  In this case, the name of the file is 
Pattern Components. The cells, on the other hand, are listed below the file name.  (The 
number of cells can become very large for an extensive mask project). 

2.11. Using Cells: 
Every file opens up with a single cell.  To open existing cells in a file, use the Cell > 
Open command.  When size becomes an issue, more cells can be made.  New cells are 
created with the Cell > New command.  

*** In naming cells, do not use parentheses or slashes/dashes of any kind.  When 
possible, do not even use spaces.  Letters (capital preferred) and numbers are 
allowed. 

Each new cell must be given a unique name.  If, in any case, a cell needs to be renamed, 
this can be done with the Cell > Rename command. 

2.12.  Instancing Cells: 



To instance a cell is to copy it into another cell.  As stated earlier, each set of detailed 
components in the project mentioned previously was instanced into the main cell called 
Test Pattern.  First, the user must access the cell into which other cells are to be 
instanced.  Then one can instance a cell through Cell > Instance in the main menu or by 
pressing the Insert key on the keyboard.  Select the cell to instance.  (Only one cell can be 
instanced at any time). 

Note:  A cell’s features can not be changed in its "instanced" form.  To make the 
necessary changes, one must return to the original cell (pre-instanced) and configure it 
accordingly.  L-Edit automatically modifies any cells in the project that carry the same 
name as the original cell. 

3.  Mask File 
When all is completed in a mask design, the file must be saved or stored in a safe 
location.   In that most mask fabricators accept mask file in the format of GSDII.  How to 
save file in GSDII will be detailed next.  

Before doing anything else, make sure that the layers in the mask design being created 
have GDSII numbers assigned to them.  Companies recognize layers in a mask design 
through the use of these numbers.  Also, it is impossible to export/import mask data 
without assigning numbers to the desired layers.  To assign a number (L-Edit allows 
numbers ranging form 1-64), simply select Setup > Layers from the main menu and 
make sure to click on the General tab on the pop-up screen.  Toward the right side of the 
screen, there is an area that reads Import/Export…GDSII number:, CIF name:. For each 
layer that is to be developed in the final mask produced by the company, a GDSII number 
must be specified. 

To export the mask design data from the computer so that the photomask company 
recognizes what it is that the customer desires, simply click on File > Export Mask 
Data.  Designate a safe area to store the exported data in the To file: section and specify 
the Export file type as GDSII.  Before proceeding with sending off the data file via e-mail 
(as an attachment), make sure that the exported data was truly exported.  In other words, 
import the data file back into the computer to check if everything appear as it should.  In 
the L-Edit main menu, select File > Import Mask Data.  Browse and find the file in 
which the initial exported data was stored.  This should be done in the From file: section, 
as shown in the diagram above.  Next, specify the Import file type.  If the initial file was 
exported as a GDSII file, it should be imported the same way.  Last, but not least, check 
to make sure the Use setup file: contains the same basic layout as the exported/imported 
file. 

If all goes well, no warnings should appear on the screen during both the export and the 
import procedures.  If warnings do appear and the error is not evident, contact the L-Edit 
Customer Support team.  

4.  Index 



4.1.  License Information: 

Tanner Research, Inc. grants a license to use the L-Edit software but does not grant the 
right to reproduce, prepare derivative works nor distribute the software.  The L-Edit 
program is owned and maintained by: 
Tanner EDA Division 
Tanner Research, Inc. 
2650 East Foothill Blvd. 
Pasadena, CA 91107 
USA 

4.2.  Help Contacts 

Staff Support: 
Helena Gleskova 
Office Phone: 609-258-4626 
Room J301 
Note: Conrad Silvestre has the program manual. Room C402 

L-Edit Customer Support: 
Telephone (626) 792-3000 
Fax (626) 792-0300 
E-mail support@tanner.com 
Web Site http://www.tanner.com/eda 
 
 


